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INTRODUCTION TO ACCESS 2010 

 

Access 2010 is a software program  (relational database software) in the Microsoft 2010 Office 

Suite that allows users to create, manage, query and run reports on large amounts of data in 

any . 

 
A database is a collection of data that is stored in a computer system. Databases allow their 
users to enter, access, and analyse their data quickly and easily. A  database is  a collection of 
tables 

 
Why Use a Database? 

 Excel is great at storing and organizing numbers, Access is far stronger at handling 

non-numerical data like names and descriptions. Non-numerical data plays a big role 

in almost any database, and it's important to be able to sort and analyse   it. 

 Access or any DBMS compared to other databases (like Excel) apart from storing data 
has connectivity among the objects.  

 A relational database has lists and the objects within them relate to one another. 

 Each Access database consists of multiple objects that let you interact with data. 
Databases can include forms for entering data, queries for searching within it, reports 
for analyzing it, and of course, tables for storing it. 

 
 
1.1 Interface elements  

The three main components of the Access 2010 user interface are: 

 The Ribbon   is the strip of tabs across the top of the program window that contains 

groups of commands. 

 The Backstage view   is the collection of commands that you see on the File tab on the 

ribbon. 

 The Navigation Pane   is the pane on the left side of the Access program window that 

lets you work with database objects.  

These three elements provide the environment in which you create and use databases. 

Ribbon 

 The ribbon   primarily consists of tabs that have groups of buttons. 

 The ribbon has main tabs that group related commonly-used commands, contextual 

tabs that appear only when you can use them, and the Quick Access Toolbar, a small 

toolbar that you can customize with required commands. 

 On the ribbon tabs, some of the buttons provide   a gallery of choices, other options  

launch a command. 

Backstage View 

The Backstage view occupies the File tab on the ribbon and contains many commands. The 

Backstage view also contains other commands that apply to an entire database file. In 

Backstage view, you can create a new database, open an existing database, publish a 

database to the Web via SharePoint Server, and perform many file and database 

maintenance tasks. 
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1.2 File Tab 

 

 

 

File Tab in Access 2010 

 

 

Navigation Pane: The Navigation Pane helps you organize your database objects, has a 

variety of ways to view objects and is the main means of opening or changing the design of a 

database object.  

 

Backstage View 
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The Navigation Pane is organized by categories and groups.  
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1.3 Objects In Access Database 

Tables In Access, data is stored in tables. A table is a set of columns and 
rows, with each column referred to as a field. Each value in a field 
represents a single type of data. Each row of a table is referred to 
as a record. 
 

Queries You use queries to retrieve specific data from your database and to 
answer questions about your data. For example, you can use a 
query to find the names of the employees in your database who live 
in a particular state. 
 

Forms Forms give you the ability to choose the format and arrangement of 
fields. You can use a form to enter, edit, and display data. 
 

Reports Reports organize or summarize your data so you can print it or view 
it onscreen. You often use reports when you want to analyze your 
data or present your data to others. 
 

Macros Macros give you the ability to automate tasks. You can use a macro 
to add functionality to a form, report, or control. 
 

Modules Like macros, modules give you the ability to automate tasks and 
add functionality to a form, report, or control. Macros are created by 
choosing from a list of macro actions, whereas modules are written 
in Visual Basic for Applications. 
 

The Ribbon 

The ribbon is the primary replacement for menus and toolbars and provides the main 

command interface in Access 2010. One of the main advantages of the ribbon is that it 

consolidates, in one place, those tasks or entry points that used to require menus, toolbars, 

task panes, and other UI components to display.  

When you open a database, the ribbon appears at the top of the main Access window, where 

it displays the commands in the active command tab. 

 

The ribbon contains a series of command tabs that contain commands. In Access 2010, the 

main command tabs are File, Home, Create, External Data, and Database Tools. Each tab 

contains groups of related commands, and these groups surface some of the additional new 

UI elements, such as the gallery, which is a new type of control that presents choices visually. 

The commands that are available on the ribbon also reflect the currently active object. For 

example, the Design tab only appears when you have an object open in Design view. 

A relational database has lists and the objects within them relate to one another. 
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1.4 Tabs 

 

Command Tab Options 

Home  
 

 Select a different view. 

 Copy and paste from the clipboard. 

 Set the current font characteristics. 

 Set the current Font Alignment. 

 Apply rich text formatting to a memo field. 

 Work with records (Refresh, New, Save, Delete, Totals, Spelling, More). 

 Sort and filter records. 

 Find records. 

 Create a new blank table. 

 Create a new table using a table template. 

 Create a list on a SharePoint site and a table in the current database that links to the 
newly created list. 

Create  
 

 Create a new blank table in Design view. 

 Create a new form based on the active table or query. 

 Create a new pivot table or chart. 

 Create a new report based on the active table or query. 

 Create a new query, macro, module, or class module. 

 Import or Link to external data. 

 Export data. 

External Data   
 

 Collect and update data via e-mail. 

 Create saved imports and saved exports. 

 Run the Linked Table Manager. 

 Move some or all parts of a database to a new or existing SharePoint site. 
 

 Launch the Visual Basic editor or run a macro. 
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Contextual Command Tabs 

In addition to the standard command tabs, Access 2010 also has contextual command tabs. 

Depending on the context (object   working with), one or more contextual command tabs might 

appear next to the standard command tabs. 

 

 

Activate a Contextual Command Tab 

1. Click the contextual command tab. 

2. The contextual command tabs contain commands and features that you need to work 

in a specific context. 

3. For example, when you open a table in Design view, the contextual tabs contain 

commands that apply only when you are working with a table in that view. 

 Galleries     

The ribbon also uses a kind of control called a gallery. The gallery control is designed to focus 

your attention on getting the results that you want.  

 

 

Database 

Tools 

 
 

 Create and view table relationships. 

 Show/hide object dependencies. 

 Run the Database Documenter or analyze performance. 

 Move data to Microsoft SQL Server or to an Access (Tables only) database. 

 Manage Access add-ins. 

 Create or edit a Visual Basic for Applications (VBA) module. 
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Hide and Restore the Ribbon 

1. Double-click the active command tab (the active tab is the highlighted tab). 

2. Double-click the active command tab again to restore the Ribbon. 

 Quick Access Toolbar (QAT) 

The Quick Access Toolbar is a toolbar adjacent to the ribbon that allows one-click access to 

commands. The default set of commands include Save, Undo, and Redo, and you can 

customize the Quick Access Toolbar to include other commands. 

  

Customize the Quick Access Toolbar 

1. Click the rightmost drop-down arrow in the toolbar. 

2. Under Customize Quick Access Toolbar, click the command that you want to         

add, and you are done. 

Or, if the command is not listed, click More Commands, and proceed to the next  step 

of this procedure. 

3. In the Access Options dialog box, select the command or commands that you want to 

add, and then click Add. 

4. To remove a command, highlight it in the list on the right, and then click Remove. 

Alternatively, double-click the command in the list. 

5. Click OK when you are done. 

Open a Database Object, Such As A Table, Form, Or Report 

1. In the Navigation Pane, double-click the object. 

-or- 

2. In the Navigation Pane, select the object, and then press ENTER. 

-or- 

3. In the Navigation Pane, right-click an object, and then click Open. 

4. Note that you can set an option to open objects with a single click in the Navigation 

Options dialog box. 

5. The Navigation Pane divides your database objects into categories, and these 

categories contain groups.  

 

To show or hide the Navigation Pane     

Click the button in the upper-right corner of the Navigation Pane     or press F11.  
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The Navigation Pane from Appearing By Default 

1. Click the File tab, and then click Options. 

The Access Options dialog box appears. 

2. In the left pane, click Current Database. 

3. Under Navigation, clear the Display Navigation Pane check box, and then 

click OK. 

 

 Status Bar 

This standard UI element continues to be the place to look for status messages, property 

hints, progress indicators, and so on. With Access 2010, the status bar also takes on two 

standard functions that you will also see in the status bar of other Office 2010 programs: 

View/Window switching and Zoom. 

The status bar can be enabled or disabled in the Access Options dialog box. 

Show Or Hide The Status Bar 

1. Click the File tab, and then click Options. 

The Access Options dialog box appears. 

2. In the left pane, click Current Database. 

3. Under Application Options, select or clear the Display Status Bar check 

box. Clearing the check box turns off the display of the status bar. 

4. Click OK. 

 

Mini Toolbar 

Using Access 2010 you can format text more easily by using the mini toolbar. When you select 

text for formatting, the mini toolbar automatically appears above the selected text. If you move 

the mouse pointer closer to the mini toolbar, the mini toolbar fades in and you can use it to 

apply bold, italic, font size, color, and so on. As you move the pointer away from the mini 

toolbar, the mini toolbar fades away.  

 

Format Text by Using The Mini Toolbar 

1. Select the text to format. 

The mini toolbar transparently appears above the text. 

2. Apply formatting by using the mini toolbar. 

 



Dr. MCR HRDIAP 

 

9 
 

Getting Help 

When you have a question, you can get help by pressing F1, by clicking the question mark 

icon on the right side of the ribbon. 

 

 You can also find Help in Backstage view: 

 Click the File tab, and then click Help. 
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WORKING WITH TABLES 

 

While there are four types of database objects in Access 2010, tables are arguably the most 

important. Even when you're using forms, queries, and reports, you're still working with tables, 

since that's where all your data is stored. Tables are at the heart of any database, so it's 

important to understand how to use them. 

 

Open A Recently Used Database 

 In Backstage view, click Recent, and then click the database that you want to open. 

 Access opens the database. 

Open A Database From Backstage View 

 Click the File tab, and then click Open. When the Open dialog box appears, browse 

and select a file, and then click Open. 

 The database opens. 

Create A New Blank Database 

1. Start Access from the Start menu 

2. Start > Programs > Microsoft Office > Microsoft Access 2010. 

The Backstage view appears. 

File Menu > New > Blank database 

Enter the name of the access database under File Name and click on Create button. 

 

 

The new database is created, and a new table is opened named Table1 as a starting point. 
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Table-1 (Default table created) 

 

 

To create the fields in the table   right click on the table and select Design View. 

A dialog box titled Save As is displayed where the Table name can be modified. 

Enter Field Name and Data Type information 
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Primary Key  

A primary key is a unique identifier for a database record. When a table is created, one of the 

fields is typically assigned as the primary key. While the primary key is often a number, it may 

also be a text field or other data type.  

The primary key also acts as a pointer to the record and provides a simple way for the DBMS 

to search, sort, and access the records. It also helps relate records across multiple tables. 

Each table can only have one primary key. The primary key field must also be defined for each 

record and not set to null.  

 

Foreign Key 

A foreign key (FK) is a column or combination of columns that is used to establish and enforce 
a link between the data in two tables. In a foreign key reference, a link is created between two 
tables when the column or columns that hold the primary key value for one table are 
referenced by the column or columns in another table. This column becomes a foreign key in 
the second table. 
 

2.1 Data Types In Access 2010  

Field Type What It Holds 

Text Text up to 255 characters long (including spaces and punctuation). Use a Text 

field, not a Number field, for codes — such as phone numbers, ZIP codes, and 

other postcodes — even if they look like numbers. 

Memo Like a Text field, but more of them — up to 65,536 characters. A memo field 

can contain rich (formatted) text, and you can set it to Append Only, so that it 

can accumulate text notes, without allowing the user to delete what’s already 

there. 

Number Only numbers. You may use + or – before the number, and a decimal point. If 

you plan to do math with a field, use a Number or Currency field. 

Currency Numbers with a currency sign in front of them ($, ¥, and so on). 

AutoNumber Numbers unique to each record and assigned by Access as you add records, 

starting at 1. Use an AutoNumber field as the primary key field for most tables. 

Date/Time Dates, times, or both. 

OLE Object Object Linking and Embedding. Don’t use it when creating a new database; 

use the new Attachment type instead because it stores data more efficiently. 

Hyperlink This text string is formatted as a hyperlink. (If you click the link, it takes you to 

the page.) This is especially useful if there’s related information on the Web. 

Yes/No Yes or no (a particular condition is, or isn’t, in effect) — or other two-word sets, 

such as True/False, On/Off, or Male/Female. Use a Yes/No field if you want to 

display the field as a check box on forms. 

Attachment You can store one or more entire files — pictures, sound, Word documents, 

even video — in one Attachment field. 

http://www.sharpened.net/glossary/definition/database
http://www.sharpened.net/glossary/definition/datatype
http://www.sharpened.net/glossary/definition/null
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Calculated You enter a formula that Access uses to calculate the value of this field based 

on other fields in the table. Use a Calculated field when a calculated value will 

be used in many queries, forms, and reports. 

 

2.2 Table in Design View 

 To start creating a table in Design View, on the Ribbon, click Create. In the Tables 
section, click the Table Design button  

 
 To open an existing table in Design View, in the Navigation Pane, right-click it and 

Click Design View. 
 If a table is already opened, to switch it to Design View, right-click its tab and click 

Design View 
 If a table is currently opened, to switch it to Design View, on the right side of the status 

bar, click the Design View button  
 
A table in Design View is divided in two sections: one in the upper area and another in the 
bottom 
 

 

 The top area is made of columns (named Field Name, Data Type, and Description) 
and rows.  

 The lower portion of the window is made of two sections. To access the lower portion 
while the top section has focus, you can press F6 or click the lower item you want. 
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 The left section of the lower part is made of two tabs labelled General and Lookup. 

 Each tab contains two columns and various rows.  

 The number of rows and the contents of cells depend on what is selected in the upper 
section.  

Create a Lookup Column 
 
If a field can contain a finite list of values, you can create a Lookup Column and users can 
select the value they want from a list. For example, if the employees at a school can only work 
in one of the following departments: Administration, Computer Science, English, History, or 
Math. You can create a table Departments table that lists the departments and then use the list 
in the Employee table to assign each employee to a department. 

Departments Table 

Department ID 
(Primary Key) 

Department 

1 Administration 

2 Computer Science 

3 English 

4 History 

5 Math 

Access has a wizard to help you create lookup columns. Creating a Lookup column creates a 
relationship between two tables.  

Lookup Wizard 
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1. Open the table to which you want to add a lookup column. 
2. Click the field label for the field before which you want to add a lookup column. 
3. Activate the Datasheet tab. (You must be in Datasheet view.) 
4. Click the Lookup Column button in the Fields & Columns group. The Lookup Wizard 

appears. 
5. Make sure the radio button next to “I want the lookup column to look up the values in a 

table or query.” is selected. 
6. Click Next. The Lookup Wizard moves to the next page. 

Select your table or query 

A lookup column can be based on a table, a query, or a list of values you type. If you base your 
lookup column on a table or query, you must create the table or query before creating the 
lookup column. A query is a list of rows and columns based on one or more tables. A query 
only displays the rows and columns you specify. 

 

1. Click a radio button to select what you want to base your lookup column on. Choose 
from Tables, Queries, or Both. 

2. Click to select the table or query you want. 
3. Click Next. The Lookup Wizard moves to the next page. 

Select fields 

You choose the fields you want to appear in your lookup column. Be sure to include the 
primary key. 
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1. Click the field you want. 
2. Click the single right-arrow button . Access places the field in the Selected Fields 

column. Repeat this process to select additional fields. If you want all the fields in the 
table, click the double right-arrow button .  

Note: Use the single left-arrow  and the double left-arrows  to deselect fields. 

3. Click Next. The Lookup Wizard moves to the next page. 

Sort fields 

The Lookup Wizard allows you to sort the records in a lookup column. You can display records 
in order, either ascending (alphabetical from A to Z, lowest number to highest number, earliest 
date to latest date) or descending (alphabetical from Z to A, highest number to lowest number, 
latest date to earliest date). You can also sort within a sort. For example, you can sort by state 
and then within each state by city, and then within each city by street address. If you are 
creating a sort within a sort, create the highest level sort on line one, the next level sort on line 
two, and so on. In the state, city, and street address example, you create the state on line one, 
the city on line two, and the street address on line three. 

 

1. Click the down-arrow and then select the field you want to sort by. 
2. Click to select a sort direction (the button toggles between ascending and descending). 

You can sort within a sort for up to four levels. 
3. Click Next. The Lookup Wizard moves to the next page. 
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1. Click the key field. 
2. Click Next. The Lookup Wizard moves to the next page. 

Name the column 

Field names appear at the top of each column. On this page of the Wizard you tell Access 
what you want to name your lookup column. In Access 2007, multiple values can appear in a 
field; click the Allow Multiple Values checkbox if you want to allow multiple values. 

 

1. Type the name you want to give the column. 
2. Click if you want to allow multiple values in the field. 
3. Click Finish. Access creates the lookup column. 

Tables Column Design 

Name of a Field 

In the Design View: 

 To create a new column and give it a name, click an empty cell under Field Name and 
type the desired name 

 To change the name of an existing column, double-click its name in the Field Name 
column to select it and type the desired name 

 To edit the name of an existing column, click somewhere in the name to put it into edit, 
use the Delete, the Backspace, and the arrow keys to edit it. 

 

Text on the Status Bar 

 To create a status bar text for a field when designing a table: 

 If the table is displaying in the Datasheet View, click any cell under its header. On the 
Ribbon, click Fields, in the Properties section, click Name & Caption. 
Click Description and type the desired text 

 If the table is displaying in the Design View, click the name of the column. Under 
Description, type the string you want 

The string would appear when the field receives focus in the table in Datasheet View 
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The Caption of a Field 

On a column of a table, a caption is the string that the user sees on the column header. The 
caption that a column displays is not necessarily the name of the column. 

 To give a desired column header in the top section of the Design View, click the field 
under the Field Name column. In the lower section of the window, click Caption and 
type the desired word or group of words 

 To change the caption of a column but keep its name, switch the table to Design View, 
under Field Name, click the field. In the lower section of the window, click Caption, 
press F2 and edit the string 

 

Notice the words in the columns headers (the captions) 
  

 

Change View 

 After designing the Table Data can be entered through the Datasheet View.  

 To open the table in DataSheet View, Right Click on the Table and Click open 

 Activate the Home tab. 

 Click the down-arrow under the View button. A menu appears. 

 Click the view you want. Access changes to the view you chose. 

2.3 Table In a Datasheet view 

A table is primarily an arranged list of columns and rows, each column and each row intersect 
to create a rectangular box called a cell: 

 
 

The cell is actually the object that holds data of a table. A cell holds only one piece of 
information.  

http://www.functionx.com/access/Lesson02.htm
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Scroll Bars 

The vertical scroll bar / horizontal scroll bar would allow you to move up and down  or left to 
right on the datasheet.  

 

Table Navigation Buttons 

The lower left side of the table is made of four buttons used to navigate the table, one button 
used to create a new record, and a text box. Each button plays a specific role: 

Button Name Role 

 

First Record Allows moving to the first record of the table 

 

Previous Record 
Allows you to move one record back (if there 
is one) from the current record 

 

Current Record 
Displays the number representing the 
current record out of the total number of 
records 

 

Next Record Allows moving you one record ahead 

 

Last Record 
Allows moving you to the last record of the 
table 

 

 New (Blank) Record Used to enter a new record on the table 
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Save the table 

 To save the table, right-click and click Save 

 Type  the name of the table 
  

 

 Click OK 

 To close the table, click its Close button  

 

2.4  Table management 

Tables in the navigation pane: The table is the primary object of a database. When you create 
a table and save it by giving it a name, Microsoft Access creates a section labelled Tables in 
the Navigation Pane and displays the name of the  new table in that section.  

 

 

Opening a table 

 To open a table, first locate it in the Navigation Pane then: 

 You can double-click the table 

 You can right-click the table and click Open 

Any of these actions causes the table to display in Datasheet View in the central area of the 
screen. 

Closing a table 

After using a table, you can close it. Before closing a table, first select its tab. Then, to close 
a table: 

 You can click the close button  on the right side of the tabs 

 You can press Ctrl + Shift + F4 
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Selecting a Table 

 To select a table in the Navigation Pane, simply click it 

 If you had opened many tables and they are displaying in the main area of the screen, 
to select one, click its tab or its title bar 

 If you have many tables displaying in the main area of the screen, you can press Ctrl + 
F6 continuously to switch from one table to the next until the desired one displays 

Renaming a Table 

If the name of a table is not appropriate, you can change it. To rename a table, in the 
Navigation Pane, you can right-click the name of the table and click Rename. 

Deleting a Table 

 In the Navigation Pane, right-click the table and click Delete 

 In the Navigation Pane, click the table to select it. Then, on the Ribbon, click Home. In 
the Record section, click Delete 

 In the Navigation Pane, click the table to select it and press Delete 

 

Working on Columns in Tables 

Changing the Width of a Column 

To change the width of a column: 

 You can position the mouse on the right border of a column header. The mouse pointer 
would change into a horizontal double arrow crossed by a vertical line: 
  

 
  
If you double-click, the column would be resized to the widest value of the column, 
provided the widest value is wider than the column header. If the widest value is 
narrower than the column header, the column width would be widened enough to 
display the name of the column. 

 You can click the column's right border and drag in the desired direction, left or right 
until you get the desired width 
  

 

 You can right-click a column's name and click Column Width... This would open the 
Column Width dialog box where you can type the desired value and click OK 
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Move a Column 

To move a column in Datasheet View, first select it. Click and hold your mouse on it. Then, 
start dragging left or right in the desired direction. While your mouse is moving, a thick vertical 
line will guide you. Once the vertical line is positioned to the desired location, release the 
mouse 

 

 

 

Move a Group of Columns 

To move a group of columns, first select them as we reviewed earlier. Click and hold the 
mouse on one of the selected columns. Start dragging left or right in the desired direction until 
the thick vertical guiding line is positioned in the desired location, then release the mouse 

 
 

 

Inserting a Column 

Inserting a column consists of adding one between two existing fields. To do this, right-click 
the column that will succeed it and click Insert Field 

Or 

 To insert a column using the ribbon, first click a cell under the column that will 
succeed it. Then, in the Fields & Columns section of the Datasheet tab, click the 

Insert button  
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 To insert a column from the table, right-click the column that will succeed it and click 
Insert Column 

 To insert a field from the Field Templates, click and drag it from the Field Templates 
and drop it to the left of the column that will succeed it 
  

 

 

 

Rename Column 

Before changing the name of a column: 

 You can double-click its header 
 You can right-click a column and click Rename Column 
 When any cell under a column has focus, on the Ribbon, you can first click Datasheet. 

Then, in the Fields & Columns section, click Rename Column.  

 

Any of these actions would put the name of the column into edit mode. You can then type 
the new desired name or change the existing name. 

 

Hiding and Revealing a Hidden Column 

To hide a column, you can drag the right border of its column header completely to its left 
border as we saw earlier to change the width of a column; when the vertical guiding line 
reaches the left border, release the mouse: the column would be hidden from the table. 
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To hide one or a group of columns, you can right-click and click Hide Fields. You can also 
right-click any column and click Unhide Fields. This would open the Unhide Columns dialog 
box.  

 

To hide a column, clear its check box. 

To reveal a column or a group of columns previously hidden, right-click any column header 
on the table and click Unhide Column.  In the Unhide Columns dialog box, put a check mark 
on each column you want to show. 

Deleting a Column 

To remove a column from a table: 
 Right-click the column's name and click Delete Field 
 Select the column (or a group of columns), right-click anywhere in the table and click 

Delete Field 
 Select a column (or a group of columns). Then, in the Add & Delete section of the 

Ribbon, click the Delete button  
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Any of these actions would present you a warning to confirm whether you still want to delete 
the column(s). 

 

Data Entry Fundamentals 

Data entry consists of entering values into the database and populating it with information. A 
table's cell holds one particular unit of data. All cells on the same (vertical) column belong to 
the same category of information.  

 

 
 
 
 
Data Entry on a Table 
 

 To perform data entry on a table, you can click a cell under a column header and 
type a value.  

 A table appears with many rows of cells, when a table is empty with no record, 
only the cells just under the column header are accessible. Those cells appear with 
a type of blue color. 

 If you click one of those cells, its background becomes white and its borders are 
orange, indicating that it is ready. 

 

 
 

 Another way to indicate an empty record, the field of the most left column is marked 
with (New) and its row of records uses the same light-blue color.  

 After typing a value in a cell, you can press Enter or Tab to move the caret to the next 
cell.  

 When a record has been completed, the background color of its cells changes. The 
next record under it has the first cell marked as (New) and its empty cells are in blue. 
The other cells remain white 
 

 

 

http://www.functionx.com/access/Lesson03.htm
http://www.functionx.com/access/Lesson03.htm
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 The white cells cannot receive data: if you click them (with the left mouse button), 
nothing happens. You can only right-click them to get a context-sensitive menu. 

 

There are three kinds of fields or cells the user will face:  

 A field in which the user can type data, 

 A field that displays a list as a combo box the user has to select from,  

 A field that does not receive input from the user.  

 After setting the data in a particular field, you can click another cell and type the 
desired data.  

 Press the right arrow key to move to the next field or the left arrow to move to the 
previous field or by pressing Enter.  

 Press Enter at the end of a record, the caret would move to the beginning of the next 
record.  

 
2.5 Record Management in Datasheet View 
  
Record Selection 

Record maintenance consists of copying, pasting, or deleting records, etc require that the 
record(s) be selected first: 

 To select a row or record in Datasheet View, click the desired row header 

 To select a record, click any cell on its row. On the Ribbon, click Home. In the Find 
section, click the Select button and click Select 

 

 To select more than one record, click and hold your mouse on one of their headers, 
then drag to cover the other desired row or rows's headers. When all desired rows are 
highlighted, release the mouse. Another technique used to select more than one row 
consists of clicking one row that will be at one end, pressing and holding Shift, and then 
clicking the row that will be at the other end. 

 

To select all records of a table: 

 Press Ctrl + A 

 Click the button at the intersection of the column headers and the row headers 

 

1. To select one record, position the mouse on the box to the left of the third record until 
the mouse turns into a right pointing arrow 
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2. Then click. 
 
 

3. Notice that all cells of the second records are highlighted 
  

 
 

4. Click the box to the left of the 7th record 
5. Press and hold Shift 
6. To select a range of records, click the box to the left of the 3rd record, and release Shift 
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7. Notice that 5 records have been selected 
8. To select all records, position the mouse on the button at the intersection of the column 

headers and the row headers 
  

 

9. Click 
  

 

 

10. Notice that all records have been selected. 
11. Click any cell in the table 

 
Record Deletion 
 You can click a row header and press Delete 
 You can right-click a row header and click Delete Record 
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1. Click Delete Record 

2. A warning message box will appear. Read it and click Yes 

3. To delete more than one record, click and hold the mouse on the box to the left of 
record number 5, then drag up to include record number 2 in the selection 
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4. On your keyboard, press Delete 
  

 

5. Read the warning message box and press Enter 
  

 

 

2.6 Data Import and Export (MS-Excel) 
 
Exporting Data from MS-Access to MS-Excel 

 Click the table. Then, on the Ribbon, click External Data. 

 In the Export section, click the Excel button  

Or  

 In the Navigation Pane, right-click the desired table, position the mouse on Export, and 
click Excel 

 This would open the Export - Excel Spreadsheet dialog box with the path where the file 
will be saved.  

 

 

http://www.functionx.com/access/Lesson05.htm
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Importing a Microsoft Excel Spreadsheet  

 
Microsoft Access allows you to import a spreadsheet from Microsoft Excel. 

 
 

 
 
 

You will see Get External Data dialog box, it shows three different options of how and to where 
database will be stored. 

 

http://www.functionx.com/access/Lesson05.htm
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Click Browse to select Excel worksheet you want to import and click Open. 

 

 

Now the Import Worksheet Wizards will open up where you can select the desired worksheet 
from the list you want to import and click Next.  
Show Worksheets 
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Show Named Ranges 

 

Click the First Row Contains Column Headings check box 
  



Dr. MCR HRDIAP 

 

34 
 

Enable the First row Contains Column Headings checkbox. As mentioned earlier, your 
worksheet must have column’s label in first row, 

 

 
 

Specify information about each of the fields you are importing. Select field/column in the area 
below and specify corresponding Field Options. 
Next step provides different options of selecting primary key (Unique Identifier). You can 
enable Let Access add primary key, or choose your own primary key by selecting column/field 
label from drop-down box. We will select the default option, i.e., Let Access add the primary 
key. Click Next. 
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Enable Save import steps to save the import steps for later use and click close. 
 

 

 

The following shows an Excel worksheet that has been imported in Access 2010. 
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Right-click on imported table and click Design View to check for the data types.  

 

 

Note: In Excel Data is in a list format; each column has a title/label in first row and contains 

similar data types (similar facts), and there is no blank rows and columns. Access recognizes 

them as fields and records.  

 

2.7 Table Relationships 
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In a relational database, relationships enable you to prevent redundant data. Relationships 
are essential because they bring the data in your tables together so you can extract 
meaningful information. 
For example, if you are designing a database that will track information about books, you 
might have a table called Titles that stores information about each book. There is also 
information you might want to store about the publisher. If you were to store all of this 
information in the titles table, the publisher’s phone number would be duplicated for each title 
that the publisher prints. 
 
A better solution is to store the publisher information only once in a separate table, Publishers. 
You would then put a pointer in the Titles table that references an entry in the Publishers table. 
 
Enforce referential integrity between the Titles and Publishers tables. Referential integrity 
relationships help ensure that information in one table matches information in another.  

Types of Table Relationships 

A relationship works by matching data in key columns, usually columns with the same name in 
both tables. In most cases, the relationship matches the primary key from one table, which 
provides a unique identifier for each row, with an entry in the foreign key in the other table.  
There are three types of relationships between tables. The type of relationship that is created 
depends on how the related columns are defined. 

 One-To-Many Relationships - A one-to-many relationship is the most common 
type of relationship. In this type of relationship, a row in table A (first table) can have 
many matching rows in table B(second table), but a row in table B can have only one 
matching row in table A. For example, the Publishers and Titles tables have a 
one-to-many relationship: each publisher produces many titles, but each title comes 
from only one publisher. 
A one-to-many relationship is created if only one of the related columns is a primary 
key or has a unique constraint. 
In Access, the primary key side of a one-to-many relationship is denoted by a key 
symbol. The foreign key side of a relationship is denoted by an infinity symbol. 

 Many-To-Many Relationships - In a many-to-many relationship, a row in table A 
can have many matching rows in table B, and vice versa. You create such a 
relationship by defining a third table, called a junction table, whose primary key 
consists of the foreign keys from both table A and table B. For example, the Authors 
table and the Titles table have a many-to-many relationship that is defined by a 
one-to-many relationship from each of these tables to the TitleAuthors table. The 
primary key of the TitleAuthors table is the combination of the au_id column (the 
authors table’s primary key) and the title_id column (the Titles table’s primary key). 

 One-To-One Relationships - In a one-to-one relationship, a row in table A can 
have no more than one matching row in table B, and vice versa. A one-to-one 
relationship is created if both of the related columns are primary keys or have unique 
constraints. 
 
This type of relationship is not common because most information related in this way 
would be all in one table. You might use a one-to-one relationship to: 

 
 Divide a table with many columns. 
 Isolate part of a table for security reasons. 
 Store data that is short-lived and could be easily deleted by simply deleting the 

table. 
 Store information that applies only to a subset of the main table. 
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In Access, the primary key side of a one-to-one relationship is denoted by a key symbol. The 
foreign key side is also denoted by a key symbol. 
 

2.8 Referential Integrity  

Referential integrity is a database concept that ensures that relationships between tables 
remain consistent. When one table has a foreign key to another table, the concept of 
referential integrity states that you may not add a record to the table that contains the foreign 
key unless there is a corresponding record in the linked table. It also includes the techniques 
known as cascading update and cascading delete, which ensure that changes made to the 
linked table are reflected in the primary table.  
 
Consider the situation where we have two tables: Employees and Managers. The Employees 
table has a foreign key attribute entitled Managed By which points to the record for that 
employee’s manager in the Managers table. Referential integrity enforces the following three 
rules: 
 
1. We may not add a record to the Employees table unless the Managed By attribute points 

to a valid record in the Managers table. 
2. If the primary key for a record in the Managers table changes, all corresponding records 

in the Employees table must be modified using a cascading update. 
3. If a record in the Managers table is deleted, all corresponding records in the Employees 

table must be deleted using a cascading delete. 
 

2.9  Create Relationships with MS-Access Tables 
 

1. On the Database Tools tab, in the Relationships group, click Relationships. 

2. The Show Table dialog box automatically appears. If it does not appear, on 
the Design tab, in the Relationships group, click Show Table. 
The Show Table dialog box displays all of the tables and queries in the database. To see 
only tables, click Tables.  
 

Drag a field (typically the primary key) from one table to the common field (the foreign key) in 
the other table 

 
The Edit Relationships dialog box appears. 
 

 

 

5. Verify that the field names shown are the common fields for the relationship. If a field name is 
incorrect, click on the field name and select the appropriate field from the list. 
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To enforce referential integrity for this relationship, select the Enforce Referential 

Integrity check box. For more information about referential integrity, see the section Enforce 

Referential Integrity 

6. Click Create. 
 
Access draws a relationship line between the two tables. If you selected the Enforce 
Referential Integrity check box, the line appears thicker at each end. In addition, again only if 
you selected the Enforce Referential Integrity check box, the number 1 appears over the 
thick portion on one side of the relationship line, and the infinity symbol (∞) appears over the 
thick portion on the on the other side of the line, as shown in the following figure. 
 
 

 

 
 To create a one-to-one relationship: Both of the common fields (typically the primary key 

and foreign key fields) must have a unique index. This means that the Indexed property for 
these fields should be set to Yes (No Duplicates). If both fields have a unique index, Access 
creates a one-to-one relationship. 
 

 To create a one-to-many relationship: The field on the one side (typically the primary key) of 
the relationship must have a unique index. This means that the Indexed property for this field 
should be set to Yes (No Duplicates). The field on the many side should not have a unique 
index. It can have an index, but it must allow duplicates. This means that the Indexed property 
for this field should be set to either No or Yes (Duplicates OK). When one field has a unique 
index, and the other does not, Access creates a one-to-many relationship. 

http://office.microsoft.com/en-us/access-help/create-edit-or-delete-a-relationship-HA010341606.aspx#BM9
http://office.microsoft.com/en-us/access-help/create-edit-or-delete-a-relationship-HA010341606.aspx#BM9
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Tip: When you create a relationship, you can view the related table as a subdatasheet of the 
primary table. Open the primary table and click the plus (+) in the far left column. The plus sign 
turns into a minus (-) sign. If the Insert Subdatasheet dialog box opens, click the table you 
want to view as a subdatasheet and then click OK. Access displays the subdatasheet each 
time you click the plus sign in the far left column. Click the minus sign to hide the 
subdatasheet. 

Tip: After a relationship has been created between two tables, you must delete the 
relationship before you can make modifications to the fields on which the relationship is 
based.  

To delete a relationship: 

1. Click the line that connects the tables. 
2. Press the Delete key. 

Tip: When you create a lookup column, Access creates a relationship between the tables but 
does not enforce integrity constraints. 
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WORKING WITH QUERIES 

Queries are an essential part of any database. They extract meaningful information from your 
database and answer key business questions. Queries are a way of searching for 
and compiling data from one or more tables. The real power of a relational database is in the 
ability to quickly retrieve and analyse your data by running a query. Queries allow you 
to pull information from one or more tables based on a set of search conditions you define. 

3.1 Query Wizard 

The Query Wizard offers the simplest approach to creating a query where in step by step you 
specify the data that the query will make available. The wizard presents the tables that are part 
of the database and you select which fields you need. Such a query is called a Select Query. 

To use the Query Wizard, on the Ribbon, you can click the Create tab and, in the Queries 
section, click Query Wizard . This would display the New Query dialog box:  

 

 

 

On the New Query dialog box, you can click Simple Query Wizard and click OK. The first 
page of the Simple Query Wizard expects you to choose the origin of the query as a table or 
an already created query. 

Select the Available fields and place under Selected Fields by clicking the single arrow in 
case all the fields are required the double headed arrow can be clicked and click Next. 
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Give a desired name to store this query and click Finish. 
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3.2 Query Design 
 
Query design consists of selecting the fields that would be part of a query. A query can be 
based on tables or on other queries. To create a query, you open the tables or queries on 
which you are going to base your query in Query Design view, and then use the options in 
Design view to create your query. 

 To display a query in Design View, from the Navigation Pane, you can right-click a 
query and click Design View 

 To start designing a new query, in the Queries section of the Create tab of the 
Ribbon, click Query Design 

1. Select the Create tab on the Ribbon and locate the Queries group. 
2. Select the Query Design command. 

 

3. Access will switch to Query Design view. In the Show Table dialog box that 
appears, select the table you would like to run a query on. Click Add, then 
click Close 
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The Query Window  

The Query window is presented like a regular window. If the database is set to show 
overlapped windows, its title bar displays its system button on the left section. This can be 
used to minimize, maximize, restore, move, resize, or close the window. Like all Microsoft 
Access window objects, the title bar displays a special menu when right-clicked: 

 

 

The right section of the title bar displays the classic system buttons of a regular window. 
 
In the top wide area of the Query window, the query displays an object (table(s), query 
(queries)) or a group of objects that was selected to create the query. The lower portion of the 
query displays boxes that would be used to perform various operations related to the query. 
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The upper and the lower sections of the query window are separated by a splitter bar that you 
can use to resize them by dragging the splitter bar up or down: 

 

 

Selecting the Columns 

To create the fields for a query, you use the table(s) or query(queries) displayed in the upper 
section of the window. Once you have decided on the originating object(s), you can select 
which fields are relevant for your query: 

 To select one field from the list, just click it 

 To select many fields on the same range, you can click one of them, press and hold 
Shift. Then click one field on the other end of the desired range 

 To select fields at random, click one of the desired fields, press and hold Ctrl; then click 
each one of the desired fields 

 To select all fields, you can click the * line on the list of fields 

 

Add Columns 

To make a field participate in a query, you have various options: 

 Once you have made your selection on the list in the top part of the query window, you 
can drag it and drop it in the bottom section of the query window 

 Instead of dragging a field or all fields, you can either double-click a field to add it to the 
query, or double-click the line with * to add all fields to the query 

 In the bottom part of the query window, click an empty Field box to show a combo box. 
Then click the arrow of that combo box and select an item from the list: 
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4. The selected table will appear as a small window in the Object Relationship 
Pane. In the table window, double-click the field names you would like to 
include in your query. They will be added to the Design Grid in the bottom part 
of the screen. 
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Executing a Query 

In the Navigation Pane, a query is represented by an icon  and a name. 
 

Executing a query consists of viewing its results but the action or outcome may depend on the 
type of query. You then click the Run button to display the results. You can save queries for 
later use. 
 
To view the result of a query: 

 

 If the query is currently closed, from the Navigation Pane: 
 You can double-click it 
 You can right-click it and click Open 

 

 If the query is already opened and it is in Design View, on the Ribbon: 

 You can click the Run button     
  You can click the View button  or you can click the arrow of the View button 

and click Datasheet View                                                                              
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Display All Records and All Fields 

Each table has an option that allows you to display all of the fields and all of the records in a 

table. This option appears on the field line on the drop-down menu as the table name followed 

by a period and an asterisk (tablename.*) 

1. Click the down-arrow in the first field on the Field row and then select 

the tablename.* option. The table name appears on the table line. 

Click the Run button. Access retrieves all of the fields and records for the table and displays 

them in Datasheet view. 

Retrieve Columns 

You can use an Access query to retrieve columns of data. On the Field line in Query Design 
view, choose the field name of each field you want to retrieve in the order you want to retrieve 
them. 

 

1. Open a table or query in Query Design view. 
2. Choose the field names you want to retrieve in the order you want to retrieve them. 
3. Click the Run button. Access retrieves the columns you chose. 
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Change from Datasheet View to Query Design View 

After you run a query, you can easily change back to Query Design view and make 

modifications to your query or create a new query. 

Change to Query Design view 

 

1. Activate the Home tab. 
2. Click the down-arrow below View in the Views group. A menu appears. 
3. Click Design View. Access changes to Query Design view. You can modify your query. 

Tip: You can also click the Design button  in the lower-right corner of the Access 
window to change to Design view. 
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Selecting a Column 

 To select a field in the lower section of the view, click the tiny bar of the column header: 

 

  
 
The whole column will be selected 

 To select a range of columns, click the column header of one at one end, press and 
hold Shift, then click the column header at the other end 

Removing a Column from a Query 

 To delete a column: 

 Once it is selected, you can press Delete 

 Right-click the column header and click Cut 

 To delete a group of columns, select them and press Delete 

 

Using Operators on Queries 

 When performing data analysis, to use the operators on a query enter the expression 
in the Criteria box(es) that correspond(s) to the column(s) 

When writing the expression, there are a few rules you should observe: 

 Each operator must be written as indicated 

 To include a letter, a character, or a string, type it between double-quotes. An example 
is "M". Another example would be "El Salvador". In some cases, if you forget to use the 
double-quotes, Microsoft Access would add them. In some circumstances, if you forget 
to use the double-quotes, Microsoft Access would not add them and the expression 
may fail. Therefore, to be on the safe side, always add the quotes yourself 

 If a date or time value is part of an expression, include it between two # symbols. An 
example would be #12/8/94#. Another example is #05/02/2004#. If you forget the # 
symbol, most of the time, Microsoft Access would not correct it and you may receive an 
error 

 All built-in constants, True, False, NULL, etc, do not use quotes 
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Using an Alias Name for a Column 

 

 

 

Right-click the column and click Properties. In the Property Sheet, click Caption and type the 
desired caption. 
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Overview of expressions 

An expression is a combination of some or all of the following: built-in or user-defined     

functions, identifiers, operators, and constants. Each expression evaluates to a single value. 
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3.3 Operators in Access 2010 

An operator is a sign or symbol that specifies the type of calculation to perform within an 

expression. There are mathematical, comparison, logical, and reference operators. Access 

supports a variety of operators, including arithmetic operators such as +, -, multiply (*), and 

divide (/), in addition to comparison operators for comparing values, text operators for 

concatenating text, and logical operators for determining true or false values.  

Arithmetic Operators 

You use the arithmetic operators to calculate a value from two or more numbers or to change 

the sign of a number from positive to negative or vice versa. 

OPERATOR PURPOSE EXAMPLE 

+ Sum two numbers. [Subtotal]+[SalesTax] 

- Find the difference between two numbers or indicate 

the negative value of a number. 

[Price]-[Discount] 

* Multiply two numbers. [Quantity]*[Price] 

/ Divide the first number by the second number. [Total]/[ItemCount] 

\ Round both numbers to integers, divide the first 

number by the second number, and then truncate 

the result to an integer. 

[Registered]\[Rooms] 

Mod Divide the first number by the second number, and 

then return only the remainder. 

[Registered] Mod 

[Rooms] 

^ Raise a number to the power of an exponent. Number ^ Exponent 
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Comparison Operators 

You use the comparison operators to compare values and return a result that is True, False, or 

Null. The constants 1 and 2 are used in the examples, but those constants can be replaced 

with identifiers, functions, or expressions. 

 

OPERATOR PURPOSE EXAMPLE RESULT 

< Returns True if the first value is less than the second 

value. 

1 < 2 True 

<= Returns True if the first value is less than or equal to 

the second value. 

1 <= 2 True 

> Returns True if the first value is greater than the 

second value. 

1 > 2 False 

>= Returns True if the first value is greater than or equal 

to the second value. 

1 >= 2 False 

= Returns True if the first value is equal to the second 

value. 

1 = 2 False 

<> Returns True if the first value is not equal to the 

second value. 

1 <> 2 True 

 NOTE   In all cases, if either the first value or the second value is null, the result is then also 

null. Because null represents an unknown value, the result of any comparison with a null value 

is also unknown. 

 

Logical Operators 

You use the logical operators to combine two Boolean values and return a true, false, or null 

result. Logical operators are also referred to as Boolean operators. 

 

OPERATOR PURPOSE EXAMPLE RESULT 

And Returns True when Expr1 and Expr2 are true. 1 < 2 And 3 < 4 True 

Or Returns True when either Expr1 or Expr2 is true. 1 < 2 Or 3 < 4 True 

Eqv Returns True when both Expr1 and Expr2 are 

true, or when both Expr1 and Expr2 are false. 

1 < 2 Eqv 3 < 4 True 
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Not Returns True when Expr is not true. Not  (1 < 2) False 

Xor Returns True when either Expr1 is true or Expr2 

is true, but not both. 

1 < 2 Xor 3 < 4 False 

Concatenation Operators 

You use the concatenation operators to combine two text values into one. 

OPERATOR PURPOSE EXAMPLE RESULT 

& Combines two strings to form one string. “road” & “map” “roadmap” 

  “road” & Null “road” 

+ Combines two strings to form one string and 

propagates null values (if one value is Null, the 

entire expression evaluates to Null). 

“road” + “map” “roadmap” 

  “road” + Null Null 

 

Special Operators 

You use the special operators to return a True or False result as described in the following 

table. 

OPERATOR PURPOSE EXAMPLE 

Is Null or Is Not 

Null 

Determines whether a value is Null or 

Not Null. 

Field1 Is Not Null 

Like "pattern" Matches string values by using the 

wildcard operators ? and *. 

Field1 Like "instruct*" 

Betweenval1 

And val2 

Determines whether a numeric or date 

value is found within a range. 

Field1 Between 1 And 10 

- OR - 

Field1 Between #07-01-07# 

And #12-31-07# 

In(val1,val2...) Determines whether a value is found 

within a set of values. 

Field1 In ("red","green","blue") 

- OR -  

Field1 In (1,5,7,9) 

Operators 

Operators such as = (equal), <> (not equal), > (greater than), or < (less than) restrict the 
records you retrieve. 
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List of operators 

Operator Meaning Field Type Entry Format 

= Equal to Character 
Number 
Date 

="DE" 
=5 
= #2/16/88# 

<>  Not equal to Character 
Number 
Date 

<>"DE" 
<>5 
<> #2/16/88# 

>  Greater than Character 
Number 
Date 

>"DE" 
>5 
> #2/16/88# 

>= Greater than or 
equal to 

Character 
Number 
Date 

>="DE" 
>=5 
> = #2/16/88# 

<  Less than Character 
Number 
Date 

<"DE" 
<5 
< #2/16/88# 

<= Less than or equal 
to 

Character 
Number 
Date 

<="DE" 
<=5 
<= #2/16/88# 

In Equal to any item in 
a list 

Character 
Number 
Date 

In("DE","NJ") 
In(5,9,17) 
In (#2/16/88#, #2/3/90#, #12/15/88#) 

Not In  Not equal to any 
item in a list 

Character 
Number 
Date 

Not In("DE", "NJ") 
Not In(5, 9, 17) 
Not In (#2/16/88#, #2/3/90#, 
#12/15/88#) 

Between Between two 
values,  
greater than or 
equal to one and 
less than or equal to 
the other 

Character 
Number 
Date 

Between  "C" And "F" 
Between 5 And 10 
Between #1/1/88# And #12/31/88# 

Not Between Not between two 
values 

Character 
Number 
Date 

Not Between "C" And "F" 
Not Between 5 And 10 
Not Between #1/1/88# And 
#12/31/88# 

Is Null The value is 
missing from the 
field 

Character 
Number 
Date 

Is Null 
Is Null 
Is Null 

Is Not Null The value is not 
missing from the 
field 

Character 
Number 
Date 

Is Not Null 
Is Not Null 
Is Not Null 

Like Like a specified 
pattern.  
* means any series 
of characters.  
? means any single 
character. 

Character 
Number 
Date 

Like "S*" 
Like "1*" 
Not Applicable 
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Not Like Not like a specified 
pattern.  
* means any series 
of characters.  
? means many 
single character. 

Character 
Number 
Date 

Like "S*" 
Like "1*" 
Not Applicable 

 

Logical Operators 

To get specific records from the tables with certain conditions,. In these example details of 

employees having salary ranges from 4000 to 6000. For this condition, we will be using AND 

logical operator and write the criteria as; 

 

 

For applying this condition like Year of Service criteria, more than 2 years And less than 6 of 

service, under Design Query window, we will write this condition under Year of Service field 

as; 
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For inserting an OR condition, just enter number of Year in OR field. For instance we also 

want to show employees who worked for 2 years. For this, we will simply add 2 in OR field. 

 

 

Negating an Expression 

To negate you can precede the string with NOT 
The result would include all records that do not include the value that was set on the right side 
of NOT.  
You can also use <> instead of NOT.  
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Using Arithmetic Operators 

An arithmetic operator can be used to create an expression that results in a calculation. 

 

 

 

IN Operator 

 

 When several "Or" conditions that apply to the same field as an alternative to typing 

values in many cells, or typing Or between each value in the same cell, you can use 

the Inoperator. 

 In the Criteria row of the field you want to query, type In, and then type your criteria 

values. Separate values with commas, and surround the whole set of values with 

parentheses. 

 When you press ENTER or click another cell to commit your changes, Access 

surrounds each condition with quotation marks, as shown in the picture.  
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Like Operator 

 In a list of people one of them is named "Moore" or some of them are named "Moore" 
and you want to find the record(s) with that name, you would use LIKE "Moore". 

 If the value you want to find is a date, include it between two # signs as in LIKE 
#8/8/1993#. 

 The most regular use of the LIKE is with strings. Example Name Starting with S Like 
“S*” 

 To specify that you want the strings that start with any character from o to r followed by 
anything, you would use LIKE "[o-r]*": 

 To find specific characters in a string, use the [] as the placeholder. Inside the square 
brackets, enter the characters separated by commas. An example would be LIKE "[a, 
h, o, y]*": 

 Instead of using a range of characters, you may want to exclude the characters of a 
specific range. To negate the filter of a range of characters, you can precede 
the LIKE operation with the NOT operator.  

 The * character on a LIKE operation is used to find many characters. If you want to find 
only one character, use the? Wildcard. LIKE "?i*" This would search for a string 
starting with any character containing i in the second place followed by any other 
characters. 

Create a Query That Uses Two or More Tables 

If you want to view data from two or more tables or queries, you can create a query that pulls 
the data from multiple tables or queries. The tables and queries from which you pull your data 
should have a relationship. 

 

 

1. Open the tables and/or queries you want to use in Query Design view. 
2. Choose the field names you want to retrieve in the order you want to retrieve them. 
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3. Choose the field names you want to sort by in the order you want to sort. Under the 
fields you want to sort by, choose Ascending or Descending. 

4. Enter your selection criteria, if necessary (Not applicable in this example). 
5. Deselect the Show button for columns you do not want to display (Not applicable in this 

example). 
6. Click the Run button. Access retrieves the columns you chose and displays the rows in 

the order you specified. 

 

 

Save a Query 

After you create a query, you can save it. You can rerun a saved query at any time. If you 
change the data on which the saved query is based, you will see the changes when you rerun 
the query. 

 

1. Click the Save button on the Quick Access toolbar. Access saves the query unless you 
are saving for the first time. If you are saving for the first time, the Save As dialog box 
appears. 

2. Type the name you want to give your query. 
3. Click OK. Access saves the query. You can now access the query by using the 

Navigation pane. 

 Tip: You can also save by right-clicking a query’s tab and then selecting Save from the menu 
that appears. Access saves the query unless you are saving for the first time. If you are saving 
for the first time, the Save As dialog box appears. Type the name you want to give the query 
and then click OK. Access saves the query. You can now access the query by using the 
Navigation pane. 

Tip: After you have saved a query, you can run it by opening the Navigation pane and then 
clicking the name of the query. 
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Modify a Query 

Once created, a query can be modified. Simply open the query in Query Design view and 
make the changes. You can add columns, change the sort order, change the criteria, and 
make other changes. 

In Query Design view, the Query Setup group offers several options that can assist you. Use 
the Insert Rows button  to insert a row in the criteria area. Click anywhere in the row before 
which you want to insert a new row and then click the Insert Rows button. 

 Use the Insert Columns button  to insert a column. Click anywhere in the column 
before which you want to insert a column and then click the Insert Column button . 

 Use the Delete Rows button  to delete a row in the criteria area. Click anywhere in 
the row you want to delete and then click the Delete Row button. 

 Use the Delete Columns button  to delete a column. Click anywhere in the column 

you want to delete and then click the Delete Column button . 

Parameter Query 

To prompt users when a query runs, you can create a parameter query. You create a 
parameter query by enclosing a question in square brackets ([]). For example, if you want to 
create a parameter query that asks users which State they want to use from the Student’s 
table, you would type [Which State?] on the Criteria line under the State column. When the 
query runs, Access will prompt the user for the answer to your question. 

 

1. Open a table or query in Query Design view. 
2. Create your query. 
3. On the Criteria line, type the prompt within square brackets. 
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4. Click the Run button. Access prompts you. 

 

5. Respond to the prompt. 
6. Click OK. Access displays the results of your query in Datasheet view. 

 

Note: If you want to make your user prompt more flexible, use one of the following formats. 

 
Like "*" & [Prompt] & "*" 

Returns all records that contain the value 
you enter. 
Example: If you enter ad, Access returns all 
records that include the 
sequence ad anywhere in the field. 

Like "*" & [Prompt] Returns all records that end with the value 
you enter. 
Example: If you enter S, Access returns all 
records that end with S. 

Like [Prompt] & "*" Returns all records that begin with the value 
you enter. 
Example: If you enter S, Access returns all 
records that begin with S. 

> [Prompt] 

  

  

Note: You can also use < (less than) ,<= 
(less than or equal to) >=, >= (greater 
than or equal to), or <> (not equal) 

Find all records with a value greater than 
the value you enter. 
Example: If you enter 5, Access returns all 
records that are greater than 5. 
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3.4 Action Queries 
 
Append Query 

Appending a record consists of adding a record to a table. An Append Query allows you to 
add records to an existing table but you do not create the records. They must be retrieved 
from one table and transferred to another table. 
To start an Append Query, start a query in the Design View. In the Query Type section of the 

Ribbon, click the Append button   .  
You will be presented with a dialog box that expects you to either select the table to which 
you will add the records, or to specify the name of a new table that would receive the 
records. If you want to add the records to an existing table, you can select it from the combo 
box. 
 

1. To execute the query, In the Navigation Pane, double-click Add New Cars to the 
Application 

2. Read the strings on the message box: 
  

 
 

3. Then click Yes 

4. Another message box will come up: 
 

 
  
Click Yes 

5. Close the query window 

Update Query 

Microsoft Access provides an action query named Update Query. An Update Query allows 

you to change the existing values of one or more columns of a table. An Update Query will 

make bulk changes to records in the record source.   

 

1. On the Design tab, in the Query Type group, click Update. 
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2. Access adds the Update to row in the query design grid. Locate the field that contains the 

data that you want to change, and then type your expression (your change criteria) in 

the Update to row for that field. 

3. On the Design tab, in the Results group, click Run. 

4. An alert message appears. 

5. To run the query and update the data, click  Yes. 
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Delete Queries 

A Delete Query deletes records from a single database table or database tables. If a condition 

is specified only that set of records are deleted .The delete query will work with a group of 

records that meet a specified criteria that you apply. You can use the delete query to remove 

all records or only records that meet the defined criteria. 

1. Click the Create tab. 

a. In the Ribbon, click Query Design. 

2. When the Show Table window appears, click the desired Table Name. 

a. Then click the  button. 

3. Click the  button. 

4. In the Ribbon, click Delete. 

5. In the field list of the table, click-and-drag the * field to the first column of the design 

grid. 
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Add Criteria 

1. In the column of the design grid, which  needs to be conditioned click in 

the Criteria row. 

2. Type: the conditional value 

3. In the Ribbon, click Run. 

 

 

Some More Examples on Queries 

Open an existing query 

If you are not familiar with the Navigation Pane, you may not know how to open a query that 
already exists. The Navigation Pane is a feature that replaces the Database Window from 
versions prior to Access 2007. You'll see the Navigation Pane along the left side of your 
screen. 

To open any database object, including a query, you can double-click the object in the 
Navigation Pane. 

Use the Northwind database to follow along with examples 

Note   Examples use a database that was created by using the Northwind 2010 database 
template. 

1. Click the File tab, and then click New. 
2. In the middle pane, under Available Templates, click Sample Templates, and then 

click Northwind. 
3. In the right pane, review the name for the database file in the File Name box, and make 

any changes to the name. You can also browse for a different file location by clicking 
the folder icon. 
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4. Click Create. 
5. Follow the directions on the Northwind Traders page (on the Startup Screen object 

tab) to open the database, and then close the Login Dialog window. 

Look at a subset of the data in a table 

Sometimes you may want to review all of the data from a table, but at other times, you may 
want to review only the data from certain fields, or you may want to review data only if certain 
fields meet certain criteria. To review some of the data in a table, you use a select query. 

Suppose that you want to review a list of products and their prices. You can create a query that 
returns product and price information by using the following procedure: 

1. Open the Northwind database that you previously set up by using these steps. 
2. On the Create tab, in the Query group, click Query Design. 
3. In the Show Table dialog box, on the Tables tab, double-click Products. 
4. Close the Show Table dialog box. 
5. In the Products table, double-click Product Name and List Price to add these fields to 

the query design grid. 

6. On the Design tab, in the Results group, click Run. 

The query runs, and then displays a list of products and their prices. 

Review data from more than one table simultaneously 

Tables in a well-designed database bear logical relationships to each other. These 

relationships exist on the basis of fields that the tables have in common. When you want to 
review data from related tables, you use a select query. 

Suppose that you want to review orders for customers who live in a particular city. Data about 
orders and data about customers are stored in two tables in the same database. Each table 

has a Customer ID field, which forms the basis of a one-to-many relationship between the two 

tables. You can create a query that returns orders for customers in a particular city, for 
example, Las Vegas, by using the following procedure: 

1. Open the Northwind database that you previously set up by using these steps. 
2. On the Create tab, in the Query group, click Query Design. 
3. In the Show Table dialog box, on the Tables tab, double-click Customers and 

Orders. 
4. Close the Show Table dialog box. 

Note the line, called a join, that connects the ID field in the Customers table and the Customer 
ID field in the Orders table. This line shows the relationship between the two tables. 

5. In the Customers table, double-click Company and City to add these fields to the 
query design grid. 

6. In the query design grid, in the City column, clear the check box in the Show row. 
7. In the Criteria row of the City column, type Las Vegas. 

Clearing the Show check box prevents the query from displaying the city in its results, and 
typing Las Vegas in the Criteria row specifies that you want to see only records where the 
value of the City field is Las Vegas. In this case, the query returns only the customers that are 
located in Las Vegas — Company L and Company AA. 

http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMsetnw
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Note that you do not have to display a field to use it with a criterion. 

8. In the Orders table, double-click Order ID and Order Date to add these fields to the 
next two columns of the query design grid. 

9. On the Design tab, in the Results group, click Run. 

The query runs, and then displays a list of orders for customers in Las Vegas. 

10. Press CTRL+S to save the query. 

The Save As dialog box appears. 

11. In the Query Name box, type Orders by City, and then click OK. 

Ask variations of a question by using parameters  

Sometimes you may want to run a query that is only slightly different from an existing query. 
You can change the original query to use your new criteria, but if you frequently want to run 
variations of a particular query, consider using a parameter query. When you run a parameter 
query, the query prompts you for field values, and then uses the values that you supply to 
create criteria for your query. 

In the previous example, you created a query that returns orders for customers who are 

located in Las Vegas. You can modify the query to prompt you to specify the city each time 
that you run the query by using the following procedure: 

1. Open the Northwind database that you previously set up by using these steps. 
2. Press F11 to display the Navigation Pane. 

 Note   This step is not necessary if the Navigation Pane is displayed. 

3. In the Navigation Pane, right-click the query named Orders by City (that you created 
in the previous section), and then click Design View on the shortcut menu. 

4. In the query design grid, in the Criteria row of the City column, delete Las Vegas, and 
then type [For what city?]. 

The string [For what city?] is your parameter prompt. The square brackets indicate that you 
want the query to ask for input, and the text (in this case, For what city?) is the question that 
the parameter prompt displays. 

 Note   Neither a period (.) nor an exclamation point (!) can be used as text in a parameter 
prompt. 

5. Select the check box in the Show row of the City column, so that the query results will 
display the city. 

6. On the Design tab, in the Results group, click Run. 

The query prompts you to enter a value for City. 

7. Type New York, and then press ENTER. 

The query runs, and then displays orders for customers in New York. 

http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMorderbycity
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But what if you don't know what values you can specify? To make your parameter more 
flexible, you can use wildcard characters as part of the prompt: 

8. On the Home tab, in the Views group, click View, and then click Design View. 
9. In the query design grid, in the Criteria row of the City column, type Like [For what 

city?]&"*". 

In this parameter prompt, the Like keyword, the ampersand (&), and the asterisk (*) enclosed 
in quotation marks allow the user to type a combination of characters, including wildcard 
characters, to return a variety of results. For example, if the user types *, the query returns all 
cities; if the user types L, the query returns all cities that start with the letter "L;" and if the user 
types *s*, the query returns all cities that contain the letter "s." 

10. On the Design tab, in the Results group, click Run. 

At the query prompt, type New, and then press ENTER. 

11. The query runs, and then displays orders for customers in New York. 

Specify parameter data types 

You can also specify what type of data a parameter should accept. You can set the data type 
for any parameter, but it is especially important to set the data type for numeric, currency, or 
date/time data. When you specify the data type that a parameter should accept, users see a 
more helpful error message if they enter the wrong type of data, such as entering text when 
currency is expected. 

 Note   If a parameter is set to accept text data, any input is interpreted as text, and no error 
message is displayed. 

To specify the data type for parameters in a query, use the following procedure: 

1. With the query open in Design view, on the Design tab, in the Show/Hide group, click 
Parameters. 

2. In the Query Parameters dialog box, in the Parameter column, type the prompt for 
each parameter for which you want to specify the data type. Make sure that each 
parameter matches the prompt that you use in the Criteria row of the query design 
grid. 

3. In the Data Type column, select the data type for each parameter. 

Make calculations based on your data 

Most of the time, you do not use tables to store calculated values that are based on data in the 
same database. For example, the Order Details table in Northwind 2007 does not store 
product subtotals, because the subtotal for any given product is calculated by using data that 
is stored in the Quantity, Unit Price, and Discount fields of the Order Details table. 

In some cases, calculated values can become out-of-date, because the values that they are 
based on change. For example, you would not want to store someone's age in a table, 
because every year you would have to update the value; instead, you store the person's date 
of birth, and then use an expression in a query to calculate the person's age. 

Use the following procedure to create a query that calculates product subtotals based on data 
from the Order Details table. 
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1. Open the Northwind database that you previously set up by using these steps. 
2. On the Create tab, in the Query group, click Query Design. 
3. In the Show Table dialog box, on the Tables tab, double-click Order Details. 
4. Close the Show Table dialog box. 
5. In the Order Details table, double-click Product ID to add this field to the first column of 

the query design grid. 
6. In the second column of the grid, right-click the Field row, and then click Zoom on the 

shortcut menu. 
7. In the Zoom box, type or paste the following: 

Subtotal: ([Quantity]*[Unit Price])-([Quantity]*[Unit Price]*[Discount]) 

Click OK. 

This is the calculated field. The calculated field multiplies the quantity of each product by the 
unit price for that product, multiplies the quantity of each product by the unit price and discount 
for that product, and then subtracts the total discount from the total unit price. 

8. On the Design tab, in the Results group, click Run. 

The query runs, and then displays a list of products and subtotals, per order. 

9. Press CTRL+S to save the query, and then name the query Product Subtotals. 

Look at summarized or aggregate data 

When you use tables to record transactions or store regularly occurring numeric data, it is 
useful to be able to review that data in aggregate, such as sums or averages. 

Access allows you to review simple aggregate data in any datasheet by adding a Total row. A 

Total row is a row at the bottom of the datasheet that can display a running total or other 
aggregate value. 

 Note   You cannot add a Total row to the datasheet of a Web query. 

You can add a Total row to the Product Subtotals query that you created in the previous 

example by using the following procedure: 

1. Run the Product Subtotals query, and leave the results open in Datasheet view. 
2. On the Home tab, in the Records group, click Totals. 

A new row appears at the bottom of the datasheet, with the word Total in the first column. 

3. Click the cell in the last row of the datasheet named Total. 

Note that an arrow appears in the cell. 

4. Click the arrow to view the available aggregate functions. 

Because the column contains text data, there are only two choices: None and Count. 

5. Select Count. 

http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMsetnw
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The content of the cell changes from Total to a count of the column values. 

6. Click the adjoining cell (the second column). 

Note that an arrow appears in the cell. 

7. Click the arrow, and then click Sum. 

The field displays a sum of the column values. 

8. Leave the query open in Datasheet view. 

Create a totals query for more complex summaries 

The Total row in a datasheet is very useful, but for more complex questions, you use a totals 

query. A totals query is a select query that allows you to group and summarize data. For 
example, suppose that you want to see total sales per product. In a totals query, you can use 

Sum, an aggregate function, to see total sales per product. 

 Note   You cannot use aggregate functions in a Web query. 

Use the following procedure to modify the Product Subtotals query to make it summarize 
product subtotals by product. 

1. On the Home tab, in the Views group, click View, and then click Design View. 

The Product Subtotals query opens in Design view. 

2. On the Design tab, in the Show/Hide group, click Totals. 

The Totals row is displayed in the query design grid. 

 Note   Although they have similar names, the Totals row in the design grid and the Total row 
in a datasheet are not the same: 

 You can group by field values by using the Totals row in the design grid. 
 You can add a datasheet Total row to the results of a totals query. 
 When you use the Totals row in the design grid, you must choose an aggregate 

function for each field. If you do not want to perform a calculation on a field, you can 
group by the field. 

3. In the second column of the design grid, in the Total row, select Sum from the 
drop-down list. 

4. On the Design tab, in the Results group, click Run. 

The query runs, and then displays a list of products with subtotals. 

5. Press CTRL+S to save the query. Leave the query open. 

Create a crosstab query to add another level of grouping 

Now suppose that you want to review product subtotals, but you also want to aggregate by 
month, so that each row shows subtotals for a product, and each column shows product 
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subtotals for a month. To show subtotals for a product and to show product subtotals for a 

month, use a crosstab query. 

 Note   A crosstab query cannot be displayed in a web browser. 

You can modify the Product Subtotals query again so that the query returns rows of product 
subtotals and columns of monthly subtotals. 

1. On the Home tab, in the Views group, click View, and then click Design View. 
2. In the Query Setup group, click Show Table. 
3. In the Show Table dialog box, double-click Orders, and then click Close. 
4. On the Design tab, in the Query Type group, click Crosstab. 

In the design grid, the Show row is hidden, and the Crosstab row is displayed. 

5. In the third column of the design grid, right-click the Field row, and then click Zoom on 
the shortcut menu. The Zoom box opens. 

6. In the Zoom box, type or paste the following: 

Month: "Month " & DatePart("m", [Order Date]) 

7. Click OK. 
8. In the Crosstab row, select the following values from the drop-down list: Row 

Headingfor the first column, Value for the second column, and Column Heading for 
the third column. 

9. On the Design tab, in the Results group, click Run. 

The query runs, and then displays product subtotals, aggregated by month. 

10. Press CTRL+S to save the query. 

Create a new table by using data from other tables 

You can use a make-table query to create a new table from data that is stored in other tables. 

 Note   A make-table query cannot be run in a web browser. 

For example, suppose that you want to send data for Chicago orders to a Chicago business 
partner who uses Access to prepare reports. Instead of sending all your order data, you want 
to restrict the data that you send to data specific to Chicago orders. 

You can build a select query that contains Chicago order data, and then use the select query 
to create the new table by using the following procedure: 

1. Open the Northwind database that you previously set up by using these steps. 
2. To run a make-table query, you may need to enable the database content by using the 

Message Bar, which appears beneath the Ribbon if the database is untrusted when 
you open it. 

 Note   If your database is in a trusted location, the Message Bar does not appear and 
enabling the content is unnecessary. 

3. Close the Login Dialog form. 

javascript:AppendPopup(this,'835884287_7')
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4. On the Create tab, in the Query group, click Query Design. 
5. In the Show Table dialog box, double-click Order Details and Orders. 
6. Close the Show Table dialog box. 
7. In the Orders table, double-click Customer ID and Ship City to add these fields to the 

design grid. 
8. In the Order Details table, double-click Order ID, Product ID, Quantity, Unit Price, 

and Discount to add these fields to the design grid. 
9. In the Ship City column of the design grid, clear the box in the Show row. In the 

Criteria row, type 'Chicago' (include the single quotation marks). 

Verify the query results before you use them to create the table. 

10. On the Design tab, in the Results group, click Run. 
11. Press CTRL+S to save the query. 

The Save As dialog box appears. 

12. In the Query Name box, type Chicago Orders Query, and then click OK. 
13. On the Home tab, in the Views group, click View, and then click Design View. 
14. On the Design tab, in the Query Type group, click Make Table. 

The Make Table dialog box appears. 

15. In the Make Table dialog box, in the Table Name box, type Chicago Orders, and then 
click OK. 

16. On the Design tab, in the Results group, click Run.  
17. In the confirmation dialog box, click Yes to confirm. 

The new table is created, and the table appears in the Navigation Pane. 

 Note   If there is already a table that has the name that you specified, that table is deleted 
before the query runs. 

18. On the Design tab, in the Results group, click Run. 

Because the Chicago Orders table exists, a warning dialog box appears. 

19. Click No to cancel the action and to dismiss the dialog box. 

Add data to a table by using data from other tables 

You can use an append query to retrieve data from one or more tables and add that data to 
another table. 

 Note   An append query cannot be run in a web browser. 

Suppose that you created a table to share with a Chicago business associate, but you realize 
that the associate also works with clients in the Milwaukee area. You want to add rows that 
contain Milwaukee area data to the table before you share the table with your associate. 

You can add Milwaukee area data to the Chicago Orders table that you created in the previous 

example by using the following procedure: 

http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMmt
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1. Open the query named "Chicago Orders Query" in Design view. 
2. On the Design tab, in the Query Type group, click Append. The Append dialog box 

opens. 

3. In the Append dialog box, click the arrow in the Table Name box, and then select 
Chicago Orders from the drop-down list. 

4. Click OK. 

The Append dialog box closes. In the design grid, the Show row disappears, and the Append 
To row appears. 

5. In the design grid, in the Criteria row of the Ship City column, delete 'Chicago', and 
then type 'Milwaukee'. 

6. In the Append To row, select the appropriate field for each column.  

In this example, the Append To row values should match the Field row values, but that is not 
required for append queries to work. 

7. On the Design tab, in the Results group, click Run. 

 Note    While running a query that returns a large amount of data you might get an error 
message indicating that you will not be able to undo the query. Try increasing the limit on the 
memory segment to 3MB to allow the query to go through. 

Change data in an automated fashion 

You can use an update query to change the data in your tables, and you can use an update 
query to enter criteria to specify which rows should be updated. An update query provides you 
an opportunity to review the updated data before you perform the update.  

 Important   An action query cannot be undone. You should consider making a backup of any 
tables that you will update by using an update query. 

 Note   An update query cannot be run in a web browser. 

In the previous example, you appended rows to the Chicago Orders table. In the Chicago 

Orders table, the Product ID field shows the numeric Product ID. To make the data more 
useful for reports, you may want to replace the product IDs with product names. To replace the 
product IDs, you must first change the data type of the Product ID field of the Chicago Orders 
table from Number to Text, so that the Product ID field can accept product names. 

You can update the values in the Chicago Orders table by using the following procedure: 

1. Open the Chicago Orders table in Design view. 
2. In the Product ID row, change the Data Type from Number to Text. 
3. Save and close the Chicago Orders table. 
4. On the Create tab, in the Query group, click Query Design. 
5. In the Show Table dialog box, double-click Chicago Orders and Products. 
6. Close the Show Table dialog box. 
7. On the Design tab, in the Query Type group, click Update.  

In the design grid, the Sort and Show rows disappear, and the Update To row appears. 

http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMappend
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8. In the Chicago Orders table, double-click Product ID to add this field to the design 
grid. 

9. In the design grid, in the Update To row of the Product ID column, type or paste the 
following: 

[Products].[Product Name] 

 Tip   You can use an update query to delete field values by using an empty string ("") or 
NULL in the Update To row. 

10. In the Criteria row, type or paste the following: 

[Product ID] Like ([Products].[ID]) 

The Like keyword is necessary because the fields that you are comparing contain different 
data types (Product ID is text data, ID is numeric data). 

11. You can review which values will be changed by an update query by viewing the query 
in Datasheet view. 

On the Design tab, in the Results group, click View, and then click Datasheet View. 

The query returns a list of Product IDs that will be updated. 

12. On the Design tab, in the Results group, click Run. 

When you open the Chicago Orders table, you will see that the numeric values in the Product 
ID field have been replaced by the product names from the Products table. 

Delete data in an automated fashion 

You can use a delete query to delete data from your tables, and you can use a delete query to 
enter criteria to specify which rows should be deleted. A delete query provides you an 
opportunity to review the rows that will be deleted before you perform the deletion. 

 Note   A delete query cannot be run in a web browser. 

Suppose that you are preparing to send the Chicago Orders table (updated in the previous 

example) to your Chicago business associate, and you notice that some of the rows contain a 

number of empty fields. You would like to remove these rows that contain empty fields before 
you send the table. You could just open the table and delete the rows manually, but you might 
find it helpful to use a delete query if there are more than a few rows that you want to delete 
and you have clear criteria for which rows should be deleted. 

You can use a query to delete rows in the Chicago Orders table that do not have a value for 
Order ID by using the following procedure: 

1. On the Create tab, in the Query group, click Query Design. 
2. In the Show Table dialog box, double-click Chicago Orders. 
3. Close the Show Table dialog box. 
4. On the Design tab, in the Query Type group, click Delete. 

In the design grid, the Sort and Show rows disappear, and the Delete row appears. 

http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMupdate
http://office.microsoft.com/en-in/access-help/introduction-to-queries-HA010341786.aspx#BMupdate


Dr. MCR HRDIAP 

 

77 
 

5. In the Chicago Orders table, double-click Order ID to add it to the grid. 
6. In the design grid, in the Criteria row of the Order ID column, type Is Null. 
7. On the Design tab, in the Results group, click Run. 
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CREATING FORMS AND REPORTS 

Access forms are much like paper forms: you can use them to enter, edit, or display data. They 
are based on tables. When using a form, you can choose the format, the arrangement, and 
which fields you want to display. This lesson teaches you how to create forms. A form 
in Microsoft Access is an object that allows users to easily add and view data in a table 

1. In the Navigation Pane, select the table you would like to use to create a form 

2. Select the Create tab on the Ribbon and locate the Forms group. Click 

the Form command. 

 

Using the Form command to create a form from the Customers table 

3. Your form will be created and opened in Layout View. 

 

 

The new form 

 

http://www.brighthub.com/guides/microsoft.aspx
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4. To save the form, click the Save command on the Quick Access Toolbar. When 

prompted, type a name for the form and then click OK. 

 

Naming and saving the form 

You can use the Navigation bars to move through the records on a form. 

 

1 Go to First Record 

2 Go to Previous Record 

3 The Current Record 

4 Go to Next Record 

5 Go to Last Record 

6 Create a New (Blank) Record 

 

4.1 Form Views 

 A view is a way of looking at an Access object. Forms have three views: Form view, Layout 
view, and Design view. You can enter, edit, and view data in Form view. You can modify a 
form in Layout view or Design view. In Layout view, you can see your data, and the form you 
see closely resembles what your form will look like when you view it in Form view. You can 
make most, but not all, changes to your form in Layout view. Design view displays the 
structure of your form. In this view you cannot see the underlying data, but you can perform 
some tasks in Design view that you cannot perform in Layout view. 

Change the view 

1. Open the form. 
2. Activate the Format tab. 
3. Click the down-arrow under the View button. A menu appears. 
4. Click the view you want. 
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Create Form with a Wizard  

The Form Wizard found in Microsoft Access makes basic form creation fast and simple. . 

 

In the first step of the Form wizard, we need to specify the fields from the Customer table that 
will appear on the form. In this case, we want all of the fields to appear. Move each of the fields 
from the Available Fields side over to the Selected Fields side as in the following figure. Then 
click on the Next button. 

 

Forms can have several different layouts or arrangement of the labels and fields on the 
screen. 

 Columnar - Places the labels to the left of each field. This is similar to a paper form. 
This layout is suitable for viewing data one record at a time. 
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 Tabular - Places the field labels at the top of the screen and the records are displayed 
below. This is similar to how a spreadsheet would display the data and is suitable for 
displaying multiple records of data at a time. 

 Datasheet - The data appears in the same fashion as when viewing or adding data to a 
table. 

 Justified - Places the labels above each field with the fields spread out on the form. 
This is suitable for viewing a single record at a time as with the columnar layout.. 

 

As a final step, give this new form the name: CustomerDataEntry and then click on 
the Finish button as shown below: 

 

The new form will be created by the wizard and then opened. It appears as in the figure below: 

http://www.holowczak.com/access/access2007/access5.html#viewtables
http://www.holowczak.com/access/access2007/access5.html#viewtables
http://www.holowczak.com/access/access2007/access7.html#columnarlayout
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4.2 Creating Reports 

Reports organize and summarize data for viewing online or for printing. A detail report displays 
all of the selected records. You can include summary data such as totals, counts, and 
percentages in a detail report. A summary report does not list the selected records but instead 
summarizes the data and presents totals, counts, percentages, or other summary data only. 
Access has several report generation tools that you can use to create both detail and 
summary reports quickly.  

Views of a Report 

Design View 

  

 From the Navigation Pane, you can right-click the report and click Design View 

 If the report is already opened, in the Views section of the Ribbon, you can click the 
arrow button under View and click Design View 

 If the report is already opened, you can right-click its tab or its title bar and click Design 
View 

In the Design View of a report, you can add, position, format, configure, and manipulate the 
necessary controls. The Design View is equipped with one or more sections. The primary 
sections are the Page Header, the Detail, and the Page Footer: 
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When a report is in Design View, the Ribbon is equipped with a Controls section in its 
Design tab. You can use those controls to populate your report. You can also select objects 
from the Field List and add them to the report. 

Print Preview 

To have an idea of what a report would look like on a printed piece of paper, you can display 
it in what is referred to as Print Preview. To do this: 

 If you have created a report using the Report Wizard, it would automatically display in 
Print Preview 

 In the Navigation Pane, you can right-click a report and click Print Preview 

 If the report is already opened, you can right-click its tab or its title bar and click Print 
Preview 

When a report appears in Print Preview, the Ribbon is made of only one tab. 

To appear realistic, a report in print preview appears as a piece of paper with margins. Its 
body is filled with the data that would be printed.  

 

 

The right side and the bottom-right side display a scroll bar each. 
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After using the Print Preview, to close it, in the Close Preview section of the Ribbon, you can 
click the Close Print Preview button. This would display the report in the view it previously had. 

 

 

Report View 

The Report View shows a report with its controls and the items in its sections but it 
does not show the margins: 

 

Unlike the Print Preview, the Report View does not distinguish where a section starts and 
where it ends. 

Layout View 

The Layout View of a report appears as a drawing board. It shows its title bar and its system 
buttons. In its body, it displays three dotted lines that represent the top section and the 
margins: 
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Sections of a Report 

Page Header and the Page Footer Sections 

When a piece of paper prints, it is made of a top section, a body, and a bottom section. To 
support this, a report can be equipped with a Page Header that represents the top part, a 
Detail section that represents the body of the report, and a Page Footer section that 
represents the bottom part. 

If you create a report using either the Blank Report or the Report Design options of the 
Reports section of the Ribbon, the report would be equipped with a Page Header and a 
Page Footer sections: 
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The Page Header represents the top section of the printed paper. Therefore, when 
designing a report, put in the Page Header the objects you want to display on each top part 
of the printed paper.  

Because the Page Footer represents the bottom part of each printed page, you can put on it 
the object(s) that would display on each page. You can use it to display the date the report is 
being printed. 

Detail Section  

The most fundamental part of a report is the Detail section, which holds the most controls of 
a report. If you create a report using one of the options from the Reports section of the 
Create tab of the Ribbon, the report would come equipped with various sections. To have 
only the Detail section, you can right-click the report and click the option of those sections to 
remove them. You may end up with only the Detail section. 

 

You can then equip it with the desired controls. 

Size of a Report  

A report has a size, which is the combination of its width and its height. When it comes to the 
height, each section has and controls its own vertical measure.  

 You can drag up or down the bottom border of the bar of the next section 
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 You can access the Property Sheet of that section and change the value of the Height 
property 

The height that a report displays in Design View is the total height of its sections. 

When it comes to the width of a report, all sections use the same measure. The width that a 
report shows in Design View is the common width of its sections. Therefore, to specify the 
width of a report: 

 You can drag left or right the right border of any section 

 
  

 

 

 You can access the Property Sheet of the form and change the value of 
the Width property 

 

To change both the height and the width of the report:  

 You can drag left, up, right, or down the bottom-right corner of the lowest section 
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You can access the Property Sheet of the report then change the values of both the Height 
and the Width fields 

Report Header and the Report Footer  

The report is the primary object used to print the data of a database.  

To support the cover and the back page, the report can be equipped with two other sections: 
The Report Header and the Report Footer sections 

 

 

 

 

If you create a report using either the Report or the Report Wizard options of the Reports 
section of the Ribbon, the report would be equipped with a Report Header and a Report 
Footer sections. If you have a report that doesn't have these sections and you want to add 

them, right-click the report and click Report Header/Footer . 
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Display When Section  

After adding a section to a report, the section would show in Design View and its contents 
would appear in the other views. If you want, you can hide the section in either the Design 
View or the other views. This characteristic is controlled by the Display When enumerated 
property. To apply it, display the report in Design View and access the Property Sheet of the 
section on which you want to control this characteristic. Click either the Format or the All tab. 

The Display When property has three options: 

 Always: This is the default value of the property. It indicates that the section will 
display in Design View and its contents would appear in all views 

 Print Only: The section will appear in Design View and Print Preview only, not in 
Report View or Layout View 
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Report View 
 

 

 
Print Preview 

 

Screen Only: The section will appear in Design View, in Report View, and in Layout View, but 
not in Print Preview 
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Use the Report Button 

The Report button creates a simple report that lists the records in the selected table or query in 
a columnar format. 

To use the Report button: 

 

1. Open the Navigation pane. 
2. Click the table or query on which you want to base your report. 
3. Activate the Create tab. 
4. Click the Report button in the Reports group. Access creates your report and displays 

your report in Layout view. You can modify the report. 

 

 Tip: After you create a report, you can save it. 

1. Click the Save button on the Quick Access toolbar. Access saves the report unless you 
are saving for the first time. If you are saving for the first time, the Save As dialog box 
appears. 

2. Type the name you want to give your report. 
3. Click OK. Access saves the report. You can now access the report by using the 

Navigation pane. 
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As with other objects, you can also save a report by right-clicking the reports tab and selecting 
Save. Saved reports appear in the Navigation pane. 

Tip: Reports created by using the Report button are plain and simple. 

Sections of a Report 

Report Header Appears at the top of the first page 
and displays the report title. 

Page Header Appears at the top of every page and 
displays the headings (field labels) 
for each column. 

Page Footer Appears at the bottom of every page 
and displays the page number and 
total number of pages. 

Detail Section Appears between the page header 
and page footer and displays the 
records from the table or query. 

Report Footer This section is optional. Appears on 
the last page of the report and 
displays summary information such 
as grand totals. 
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Use the Report Wizard 

The Report Wizard provides you with more flexibility than you get by using the Report button. 
You can choose the tables and fields, group the data, sort the data, summarize the data, 
choose a layout and orientation, apply a style, and title your report.  

Create a report by using the Report Wizard: 

Open the Report Wizard 

 

1. Activate the Create tab. 
2. Click Report Wizard in the Reports group. The Report Wizard appears. 

Select tables, queries and fields 

When using the Report Wizard, you can use fields from multiple tables and/or queries if the 
tables/queries have a relationship. 

 

1. Click the down-arrow next to the Table/Queries field and then click the table from 
which you want to select fields. 

2. Click a field and then click the single-right arrow to select a single field, click the 
double-right arrows to select all fields, click a field and then click the single-left arrow to 
deselect a single field, or click the double-left arrow to deselect all fields. 

3. Repeat steps 1 and 2 for each table from which you want to select fields. 
4. Click Next. The Report Wizard moves to the next page. 
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Group 

When using the Report Wizard, you can group data. Grouping puts all of the values in a field 
into a group based on the field’s value. For example, if your data is grouped by the Department 
field and the records in the Department field have values such as Administration, Computer 
Science, and English. Access will group all of the data for the Administration department 
together, all of the data for the Computer Science department together, and all of the data for 
the English department together. 

 

1. Click to select the field by which you want to group your data. You may not see this 
page of the wizard if you are selecting data from a single table. 

2. Click Next. The Report Wizard moves to the next page. 

 

3. Click a field you want to group by. 
4. Click the right-arrow to select a field; click a field and then click the left arrow to 

deselect a field. Use the up- and down-arrows to change the order of the groupings. If 
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you are only using one table, this may be your first opportunity to select a field to group 
by. 

5. Repeat steps 3 and 4 for each field you want to group by. 
6. Click Next. The Report Wizard moves to the next page. 

 

1. Click the down-arrow and then select the field you want to sort by. 
2. Click the button to choose ascending or descending order. Clicking the button toggles 

between Ascending and Descending. You can sort up to four levels. 
3. Click the Summary Options button. The Summary Options window appears. 

 

4. Click to select the summary data you want. 
5. Click to select whether you want detail and summary data or if you want summary data 

only. 
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6. Click if you want to calculate the percent to the total for sums. 
7. Click OK. The Summary Options window closes. 
8. Click Next. The Report Wizard moves to the next page. 

Layout and orientation 

You can choose the layout and orientation of your report. The layout determines where each 

field appears on the page. Access provides three options to choose from: Stepped, Block, and 

Outline. When you choose an option, the left side of the window displays a graphic of the 

layout. 

Orientation determines whether Access creates the report in portrait or landscape. Most 
paper, such as paper sized 8 1/2 by 11, is longer on one edge than it is on the other. If you print 
in Portrait, the shortest edge of the paper becomes the top of the page. Portrait is the default 
option. If you print Landscape, the longest edge of the paper becomes the top of the page. 

 

1. Click to select a layout. 
2. Click to select a page orientation. 
3. Choose the Adjust  The Field Width So All Fields Fit On A Page option if you want all 

fields to fit on a single page. 
4. Click Next. The Report Wizard moves to the next page. 

Create a title 

On the final page of the Report Wizard, you can title your report. The title appears at the top of 
the report and on the Navigation pane. 
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1. Type the title you want to give the report. 
2. Click Finish. Access creates, saves, and opens your report in Layout view. 

 

 Tip: Reports created with the Report Wizard may have the following two sections in addition 
to the sections found in reports created by using the Report button. 
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4.3 Modify a Report 

After you create a report, you can modify it. You can add groups or sorts, add fields, change 
labels, and perform many other tasks. 

You can view a report in Report view, Layout view, Design view, and Print Preview. You can 
modify a report in Layout view or Design view. In Layout view, you can see your data, and the 
report you see closely resembles how your report will look when you print it. You can make 
most, but not all, changes to your report in Layout view. Design view displays the structure of 
your report. In this view you cannot see the underlying data, but you can perform some tasks 
in Design view that you cannot perform in Layout view. This tutorial focuses on Layout view. 

To change to Layout view: 

1. Open your report. 
2. Activate the Home tab. 
3. Click the View button. A menu appears. 
4. Click Layout View. Access changes to Layout view. 

Change the Size of a Field or Label 

If the data in a field or label seems crowded, if some of the data in the field or label does not 
appear, or if the data appears as pound signs (####), the field or label is too small. 

 

To change the size of a field or label: 

1. Click the field or label. A border appears around it. 
2. Click a side of the border and drag outward to increase the width. Click a side of the 

border and drag inward to decrease the width. 

Tip: Incidentally, if you want to change the height of records, click the top or bottom of a field 
border and drag upward or downward. 

Sections of a Report 

Group Header Appears before a group and displays 
information about the group. 

Group Footer Appears after a group and 
summarizes the group data. 
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Add a Group or Sort 

When you create a report by clicking the Report button, you are not given options that enable 
you to group or sort. You can use the Group & Sort button on the Format tab to create a group 
or sort. When you create a report by using the Report Wizard, you can use the Group & Sort 
button to add or modify a group or sort. 

To Group or Sort: 

Open the Group, Sort, and Total pane 

 

1. Open your report in Layout view. 
2. Activate the Format tab. 
3. Click Group & Sort in the Grouping and Totals group. The Group, Sort, and Total pane 

appears. 

Add a group 
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4. Click Add A Group and then select the field by which you want to group. Access groups 
and sorts the field. 

Add a sort 

 

5. Click Add A Sort and then select the field on which you want to sort. Access sorts the 
field. 

Groups and sorts display in the Group, Sort, and Total pane in levels. Access performs the 
highest-level group or sort first, the second level next, and so on. 
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After you have added a group or sort, you can set several options by clicking the More button 
and then clicking the down-arrow next to each option and making your choices. 

 

Group, Sort, and Total Pane Options 

Option Description 

Sort order 
With A on top 
From smallest to largest 
From oldest to newest 

Use these options to choose from 
ascending or descending order. 

Group interval Set how you want to group. For example, 
if you want to group by the first letter of the 
last name so that all As are together, all 
Bs are together. etc., you can select By 
First Character. 

Totals Select the field you want to total on and 
the type of total you want. Your total can 
be a sum, average, count, etc. You can 
also choose whether you want to show a 
grand total, totals as a percentage of a 
grand total, display totals in the header, or 
display totals in the footer. 

Title Allows you to add or change the field 
label. 

With or without a header section Group headers precede each group. This 
option allows you to determine whether 
you want a header section. 

With or without a footer section Group footers are printed at the bottom of 
each group. This option allows you to 
determine whether you want a footer 
section. 

Keep group together Use these options to determine where a 
page break will occur when you print: 
Do not keep group together on one 
page. This option allows page breaks 
within a group. 
Keep whole group together on one 
page. This option prevents page breaks 
within a group. 
Keep header and first record together 
on one page. This option prevents a 
header from printing at the bottom of a 
page with no records. 

There are three buttons on the right side of the Group, Sort, and Total pane. If you want to 
delete a group or sort, click the group or sort you want to delete and then click the Delete 
button. Groups and sorts execute in the order they are listed in the Group, Sort, and Total 
pane. If you want to change the order of execution, click the group or sort you want to move up 
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or down and then click the Move Up or Move Down button to move a group or sort up or down 
a level. 

To add a field: 

 

1. Open your report in Layout view. 
2. Activate the Format tab. 
3. Click the Add Existing Fields button in the Controls group. The Field List pane appears. 
4. Click Show All Tables if the field you want to add does not appear. 
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5. Click the field you want to add and drag it onto your report. A thick line appears on the 
report. Access places the field before the line. If you want the field to appear in the 
detail area, be sure to drag it to the detail area. 

To delete a field: 

1. Open your report in Layout view. 
2. Click the field you want to delete. 
3. Press the Delete key. Access deletes the field. 

To move a column: 

1. Open your report in Layout view. 
2. Click the column label. 
3. Drag the column to the new location. Access moves the column to the new location. 

To change a title: 

1. Open your report in Layout view. 
2. Double-click in the Title field. 
3. Click and drag to select the current title. 
4. Type a new title. 
5. Click anywhere outside the Title field. Access changes the title. 

To change a field label: 

1. Open your report in Layout view. 
2. Double-click the field label. 
3. Click and drag to select the label name. 
4. Type the new label name. 
5. Click anywhere outside the label. Access changes the field label. 

To change the paper size: 

1. Open your report in Layout view. 
2. Activate the Page Setup tab. 
3. Click the Size button in the Page Layout group. A menu appears. 
4. Click the size of the paper you are going to print on. 

To change paper orientation: 

1. Open your report in Layout view. 
2. Activate the Page Setup tab. 
3. Click Portrait or Landscape to choose the orientation you want to use. Access changes 

the page orientation. 

To change margins: 

1. Open your report in Layout view. 
2. Activate the Page Setup tab. 
3. Click the Margins button in the Page Layout group. A menu appears. 
4. Click the margin size you want. Access changes the page margin. 
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To add page numbers: 

1. Open your report in Layout view. 
2. Activate the Format tab. 
3. Click the Insert Page Number button  in the Controls group. The Page Numbers dialog 

box appears. 
4. Click a radio button to choose a format. 
5. Click a radio button to choose a position. 
6. Click the down-arrow in the Alignment field and then choose an alignment. 
7. Deselect Show Number On First Page if you do not want the page number to appear 

on the first page. 
8. Click OK. Access places the page number in your report. 

To add current date or time: 

1. Open your report in Layout view. 
2. Activate the Format tab. 

3.  Click the Date and Time button  in the Controls group. The Date and Time dialog 
box appears. 

 

4. Deselect the Include Date box if you do not wish to include the date. 
5. Click to select a format if you are including the date. 
6. Deselect the Include Time box if you do not wish to include the time. 
7. Click to select a format if you are including the time. 
8. Click OK. Access places the date and/or time in your report. 

 

 

 

 



Dr. MCR HRDIAP 

 

105 
 

4.4 Apply an AutoFormat 

You can use the AutoFormat option on the Format tab to apply formats such as background 
colors, fonts, and font sizes quickly. 

To apply an AutoFormat: 

1. Activate the Format tab. 
2. Click AutoFormat. The AutoFormat menu appears. 
3. Click the format you want to apply. 

Change Fonts and Formats 

You can use options on the Format tab to manually apply formats to your report. You must 
select the field or field label by clicking it before you apply. To select multiple items, hold down 
the Shift key and then click each item you want to select. A box surrounds selected items. 

Change Fonts and Formats 

Button Shortcut 
Key 

Function 

Layout View—Format Tab, Font Group 

 

  Apply a font to the current selection. 

 

  Set the size of the font for the current 
selection. 

 

Ctrl-b Bold the current selection. 

 

Ctrl-i Italicize the current selection. 

 

Ctrl-u Underline the current selection. 

 

Ctrl-l Left-align the selection. 

 

Ctrl-r Right-align the selection. 

 

Ctrl-e Center the selection. 

 

  Change the font color. 

 

  Change the background color. 

 

  Change the alternating color. For example, 
you can have every other row in the detail 
area appear in alternating colors. 

Layout View—Format Tab, Formatting Group 

 

  Apply a Number format. 

 

  Use a currency symbol. 

 

  Change to percent. 

 

  Use thousand separators. 
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  Increase decimal places. 

 

  Decrease decimal places. 

Layout View—Format Tab, Gridlines Group 

 

  Add gridlines. 

 

  Change the weight of gridlines. 

 

  Change the style of gridlines. 

 

  Change the color of gridlines. 

Layout View—Format Tab, Controls Group 

 

  Add a logo. 

 

  Add a title. 

 

  Set line thickness. 

 

  Set line style. 

 

  Set line color. 

Tip: After you modify your report, you must save it if you want to keep the changes. To save, 
click the Save button on the Quick Access toolbar or right-click the report’s tab and then click 
Save. 

4.5 Create Mailing Labels 

In Access, the easiest way to create a mailing label is to use the Label Wizard. The Label 

Wizard extracts name and address data from your database and formats it so you can print it 

on commercially available labels. 

Each time you view or print labels, the data are extracted from the database, so as you update 
your database, Access updates your labels. 

To create labels: 

Open the Labels Wizard 
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1. Click the table or query you want to use to create a label. 
2. Activate the Create tab. 
3. Click Labels in the Reports group. The Labels Wizard appears. 

Choose a product number 

Most commercially available labels have a product number. You should be able to find the 
number on the box. You use the product number to tell Access the dimensions of your labels 
and the number of columns and rows that are on a page. 

 

 

1. Click to select the Product Number in the Product Number field. 
2. Click Next. The Label Wizard moves to the next page. 

Choose a font, font size, font weight, and color 

A font is a set of characters (text) represented in a single typeface. Each character within a 
font is created by using the same basic style. The Label Wizard has options that allow you to 
select a font, font size, weight, and color. You can also choose to italicize or underline the text 
in your labels. 
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1. Click the down-arrow next to the Font Name field and then select the font. A preview 
appears in the Sample box. 

2. Click the down-arrow next to the Font Size field and then select the font size. A preview 
appears in the Sample box. 

3. Click the down-arrow next to the Font Weight field and then select the font weight. A 
preview appears in the Sample box. 

4. Click the button next to the Text Color field and then select a color you want your text to 
have. A preview appears in the Sample box. 

5. Click the Italic box if you want to italicize. A preview appears in the Sample box. 
6. Click the Underline box if you want to underline. A preview appears in the Sample box. 
7. Click Next. The Label Wizard moves to the next page. 

4.6 Create a layout 

You create the layout of your labels by selecting fields and placing them in the Prototype Label 
box. You type any text or spaces that you want to appear on your label. 
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1. Click a field name and then click the right-arrow to place the field on the prototype 
label. 

2. Press the spacebar to leave spaces. 
3. Press the Enter key to move to a new line. 
4. Type any text you want to appear on the label. 
5. Click Next. The Label Wizard moves to the next page. 

Sort 

When creating labels, you can sort on any field and you can have multiple levels of sort. For 
example, you can sort by last name and then by first name. 

 

1. Click to choose the fields you want to sort by. Click the single right-arrow to select a 
single field, click the double right-arrow to select all fields, click the single left-arrow to 
deselect a single field, click the double left-arrow to deselect all fields. 

2. Click Next. The Label Wizard moves to the next page. 
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Title the report 

 

 

1. Type a title for your report. The title will appear in the Navigation pane. 
2. Click Finish. Access displays the labels in Print Preview. 

 

Tip: When you complete your labels you may get the following message. 

When printing mailing labels, you can usually ignore this message. Click the Show Help button 
to read the following: 
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Tip: When you view labels in Report view, they may appear in a single column. To see how 
your labels will appear when printed, use Print Preview. 

4.7 Print a Report 

 In Print Preview, you can see exactly how your report will look when printed, you can make 
changes to it, and you can print it. To print, click the Print button in the Print group. The Print 
dialog box opens and you can select your print options. 

After creating a report, you have many options to print it. The fastest option consists of sending 
the report directly to the printer. To do this: 

 In the Navigation Pane, right-click the report and click Print... 

 Click File and click Print. This would display a window with three options: 

 

 To send the document directly to the printer, click Quick Print. 

 

This message may be the result of using a report created with the Label Wizard. This error 
message is commonly encountered when printing to label pages that have three or more 
labels per row. Usually this message can be ignored. 
If you do need to change the layout, try one or both of the following: 

 Reduce the width of the controls on the report. 
 Reduce the width of the report to make sure the report is not wider than the printable 

area of the page. 

Note that page size is dependent on the printer and the physical size of the paper you are 
printing to. In some cases it is necessary to rotate the page orientation from portrait to 
landscape to accommodate the selected print width. 
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Change to Print Preview: 

1. Open your report. 
2. Activate the Home tab. 
3. Click the down-arrow under the View button. A menu appears. 
4. Click Print Preview. Access changes to Print Preview. 

Several options are available to you in Print Preview. 

Print Preview Options 

Print Displays the Print dialog box. You can select such 
options as the printer, print range, and number of 
copies. Use this option to print your report. 

Size Click the Size button to set the size of the paper you 
are going to print on. 

Portrait Click the Portrait button to print with the shortest side 
of the paper as the top. 

Landscape Click the Landscape button to print with the longest 
side of the paper as the top. 

Margins Click the Margins button to select a margin size of 
Normal, Wide, or Narrow. Margins define the amount 
of white space that surrounds your report. 

Print Data Only Prints the report data without other elements such as 
titles, and labels. 

Zoom Changes the cursor to a magnifying glass. When the 
magnifying glass displays a minus sign (–), you can 
zoom out. When the magnifying glass displays a plus 
sign (+), you can zoom in. 
Click the down-arrow under the Zoom button to display 
a menu and choose a zoom level. 

One Page Displays one page of the report in the Access window. 

Two Page Displays two pages of the report in the Access window. 

More Pages Displays a menu from which you can choose the 
number of page you want to display. 

Tip: To view a report online, use Report view. Open your report. Activate the Home tab. Click 
the down-arrow under the View button. Click Report view. Your report displays in Report view. 
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